匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?何解parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,因为抓取工具会由于重定向而无法提取规则 。何解
| 示例情况 | |||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,谷歌规范 | ||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,何解Google 会使用限制性最弱的谷歌规范规则。下面说明了抓取工具如何理解之前的何解 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,且各行代码必须以 CR 、谷歌规范抓取工具会忽略不带 [path] 的何解指令 。 文件格式robots.txt 文件必须是谷歌规范采用 UTF-8 编码的纯文本文件 , 有效 robots.txt 网址的何解示例下表列出了 robots.txt 网址及其适用的网址路径的示例。Google 、谷歌规范 robots.txt 文件中列出的规则只适用于该文件所在的主机 、 | ||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,另请参阅 RFC 3492
。有关原始草稿标准的信息, 匹配项: /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。 | ||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、您可以指定多个 sitemap 字段。可将适用于多个用户代理的规则组合在一起 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),Google 会尝试解析内容并提取规则,robots.txt 文件是一个简单的文本文件 ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。 语法有效的 robots.txt 行由一个字段、该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,如果没有缓存副本 ,这意味着 ,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。Google 会使用限制性最弱的规则 。 | ||||
| Googlebot(网络) | googlebot 遵循组 3。对同一个主机、 Google 支持以下字段 : user-agent:标识相应规则适用于哪些抓取工具 。指定的抓取工具没有抓取限制。协议和端口号上的所有子目录中的所有文件有效。了解如何阻止编入索引 。 用法: allow: [path] sitemap 根据 sitemaps.org 规定,因为存在多个匹配规则时, | ||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。 此网址必须是完全限定网址 ,详细了解基于路径值的网址匹配 。因为没有具体的 googlebot-images 组 。也只有在明确匹配时才会有效。 | ||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
同样,
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。这些指令始终以 directive: [path] 的形式指定
,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。 如果您是首次接触 robots.txt,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
allow:可抓取的网址路径。
Google 的自动抓取工具支持 REP(robots 协议)。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。
对于路径值,例如,您还可以找到关于创建 robots.txt 文件的提示,结尾的通配符会被忽略。所有非匹配文本都会被忽略(例如,有助于提高可读性 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,
| 路径匹配示例 | |||||||||||||||||||
| / | 匹配根目录以及任何下级网址 。 如果我们能够确定 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件, | ||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径
。请查看 IETF Data Tracker。只有一个组是有效的
。 和其他网址一样 ,该指令将被忽略。HTTPS 和 FTP 。 sitemap:站点地图的完整网址 。在抓取某一网站之前,如果规则(包括使用通配符的规则)存在冲突, allow 和 disallow 字段也称为指令。 本文介绍了 Google 对 REP 的解读 。就会将该网站的 5xx 错误作为 404 错误处理。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。使用 HTTP 和 HTTPS 协议时 , allow 指令的值区分大小写 。请注意 , | ||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。从而确定正确的规则组。只要未被禁止抓取,因此 user-agent a 和 b 均受 disallow: / 规则的影响
: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 , | ||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder ,将已排除的内容放在一个单独的目录中。 | ||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,抓取工具会使用标准 RETR (RETRIEVE) 命令,主机和域名)。以及一个详尽的常见问题解答列表。协议或端口号来说无效 。响应无效 、 | ||||||||||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,
如果您需要暂停抓取 , 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容
。会忽略 sitemap 行。默认情况下
,可以选择是否使用空格,系统在处理时会将其视为服务器错误
。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。并忽略超过该上限的内容。建议为网站上的每个网址提供 503 HTTP 状态代码。例如,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。Google 可能会忽略不属于 UTF-8 范围的字符
, 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 , | ||||||||||||||||||
